Rocket Beans Community

RocketbeansTV Picture in Picture für Windows (GEMA Update!)


#61

Vielen Dank! Es wäre noch interessant ob du den Internet Explorer installiert oder ihn runter geworfen hast?
Ach und ob dein Betriebssystem eine N-Version ist (ohne Windows Media Player etc. Falls du es nicht weißt, hast du wahrscheinlich die normale Windows Version ) :slight_smile:

[Ich editiere mal meinen post und weise auf die Punkte hin :thumbsup: )


#62

Läuft @ Windows 10 Pro 64 Bit , normal
Nur Microsoft Edge


#63

Perfekt, danke!


#64

Zunächst mal danke, dass du die Anwendung weiterhin aktuell hältst.
Vor und während des Umstiegs lief der Youtube-Stream bei mir einwandfrei. Aber seit ich die alte Version 3 gelöscht habe, lädt der Stream nicht mehr und ich bekomme die Meldung "Please stand by". Bemerkenswert ist auch, dass der Player auf die Flash-Version umspringt, obwohl ich im Browser die HTML5 Version des Streams anschauen kann.
Ich nutze Windows 7; Internet Explorer, .Net Framwork und Flash sind auf dem neusten Stand.


#65

Hey, hm das klingt komisch.
Probiere ggf. mal die Version neu in einen anderen (leeren) Ordner zu entpacken und von dort zu starten.
Als es noch funktioniert hatte, hattest du da die HTML5 Version? Funktioniert der Chat? (Ohne HTML5 bleibt das Fenster quasi leer). Lädt der Sendeplan korrekt? Hattest du vorher die alte und die neue Version im gleichen Ordner?


#66

Hey, läuft wieder super das Tool (sogar besser als mit Twitch).

Wäre aber schön wenn du noch den minimieren-Button einbauen könntest. Ich weiß es gibt das Shortcut, aber manchmal ist bei mir z.B. nur die Maus greifbar und da fehlt dann halt nen Button. :slight_smile:

Und schön wäre es auch noch, wenn du noch ein Plätzchen für die aktuellen Zuschauerzahlen finden könntest. Sonst Mega gut :ok_hand:


#67

Chat und Sendeplan funktionieren einwandfrei.
Ich hatte tatsächlich die neue und alte Version im gleichen Ordner, allerdings in zwei verschiedenen Unterordnern. Habe aber die neue Version seitdem mehrmals neu heruntergeladen und auch in einen neuen Ordner gepackt.
Ob es zuvor mit HTML5 oder Flash funktioniert hat, habe ich mir leider nicht gemerkt. Beim Start der Anwendung blitzt übrigens kurz die Meldung "Die aktuelle Version des Flash Players wird benötigt" auf.


#68

Ah da war ja was!
Besucherzahlen sind kein Problem (würde es neben die Versionsnummer packen). Minimieren wird schon schwieriger, da ich eigtl. nicht noch einen Button in die Titelleiste packen möchte (damit alle Schaltflächen noch gut Sichtbar sind, auch wenn das Fenster sehr klein ist). GGf. halbiere ich den Maximieren Button :slight_smile:

@HerrJemine Wenn du Youtube im Internet Explorer öffnest, hast du aber die HTML5 Version? Welche Version vom IE hast du installiert? (u.U. hilft es IE zu aktualisieren)
Alternativ: Beende mal die PIP app und gehe in diesen Ordner:

C:\Users\[WINDOWS_BENUTZER_NAME]\AppData\Local\DanielKorgel.de\

und lösche alle Ordner die dort drin enthalten sind. (Der AppData Ordner ist standardmäßig versteckt. Ggf. klappt es dann wieder mit flash)


#69

wäre cool, wenn du das noch mit einbauen könntest. Halbieren der Buttons ist ja schonmal eine mögliche Lösung :wink:

Ist das eigentlich normal, das ich jetzt ne Durchschnittliche CPU Last von 50-60% allein durch die App habe? Hätte gedacht dass ohne Flash das ganze besser wird :confused:


#70

Eigtl. Nein. Ich habe bei meiner CPU (i7 6700k) mit eingeschaltetem Chat und 1080@60 Quallität max. 10% für die App. Ohne Chat und bei geringerer Qualität sollte die CPU last entsprechend sinken.
(Bei einem kleinem Fenster macht Full HD, ja ohnehin keinen Sinn. Ich habs meistens auf 720 . Bei der automatischen Auswahl, wählt YT automatisch selbst eine angemessene Qualität.)
Wenn du den Cursor über dem Video Fenster bewegst, steigt die CPU Last ebenfalls ein wenig.
Steht bei dir unten rechts "Youtube Gaming", wenn die Spulleiste eingeblendet ist? Ansonsten nutzt die App bei dir den Flash Fallback.


#71

Also unten rechts steht Youtube Gaming, somit nutzt er wohl die Non-Flash Variante.

Meine CPU ist eine AMD Phenom II X4 965 mit 3.40 GHz dazu gesellen sich 8GB Ram.
Das Fenster ist bei mir immer auf fast voller Größe, da es auf dem zweiten Monitor liegt. Qualli ist auf automatisch und somit auf 1080p. Ansonsten läuft bei mir aktuell nix weiter im Hintergrund.


#72

Jetzt wirds kurios: Youtube-Videos werden im IE als HTML5 abgespielt, der Rbtv-Stream läuft allerdings in der Flash-Version. Der IE ist auf dem neusten Stand (Version 11.0.9600.18426, Window 7 32bit).
Löschen der Appdata-Ordner hat auch nichts geändert.


#73

Hm, das werde ich im Auge behalten. Du könntest, wenn du Lust hast, mal schauen ob IE, wenn du den Stream über den youtube gaming link aufrufst genauso viel zieht https://gaming.youtube.com/watch?v=mT0TbIqBliw

@HerrJemine Auch wenn du Youtube Gaming auf den Stream gehst? https://gaming.youtube.com/watch?v=mT0TbIqBliw
Ich bin ehrlich gesagt ein wenig überfragt, wie es dazu kommen kann... evtl. werden alle Livestreams via flash abgespielt und nur videos via html5?


#74

Also im IE liegt die Auslastung bei unter 10%


#75

Genau so ist, keine Ahnung warum.

Ich kann per Aktivierung der AktiveX-Filterung die Nutzung des Flashplayers verhindern und der IE öffnet den Stream dann auch mit HTML5; allerdings kommt dann eine Fehlermeldung, die sich über das Fehlen des Flash-layers beschwert:

In einem Forum habe ich gelesen, dass wohl die Werbung trotz HTML5 immernoch Flash benötigt. Allerdings hilft auch das Aktivieren des Adblockers nicht weiter.

Das Problem liegt jedenfalls nicht bei der PiP-Anwenung. Danke trotzdem für deine Hilfe.

EDIT: Offensichtlich unterstützt die Windows 7 32bit Version vom IE nicht alle Funktionen von HTML5:

Schade.


#76

Danke für das Update! Nutze dein Tool seit der ersten Version. :slight_smile:

Zwei etwas kleinere Sachen, die mir aufgefallen sind:
- Im Vollbildmodus verschwindet die obere Leiste nicht, egal, wo ich den Cursor hinpacke.
- Manchmal reagiert das Fenster beim verschieben ein wenig widerspenstig (es hakt).

Ansonsten perfekt. :clap:


#77

Hm, das ist natürlich blöd, auf Reddit hat jemand das gleiche Problem wo er davon ausgeht, dass es an der fehlenden Unterstützung für die Media Source Extensions liegt. Bei ihm funktioniert es mit Flash jedoch problemlos :confused:

@DerUserX Den Vollbild Modus werde ich beim nächsten Update fixen, ein aktueller Workaround wäre den Cursor auf einen anderen Monitor zu verschieben, dann blendet sich alles wie gewünscht aus.
Das Haken beim verschieben ist mir auch schon aufgefallen, ein Workaround für die aktuelle Version ist, das Fenster langsamer zu verschieben. Es passiert wohl, wenn man den Cursor so schnell bewegt, dass das Fenster nicht hinter herkommt und der Cursor nicht mehr über der Titel leiste ist.

Beide Probleme schaue ich fürs nächste Update nochmal an! :slight_smile:

@Der_D: Das ist sehr komisch.... ich schau mal ob ich irgendwelche stellen finde die bei manchen CPUs Probleme machen könnten :thumbsup:


#78

Ich danke dir für deine Mühen :slight_smile: Weiter so :thumbsup:


#79

Mahlzeit,

erst mal danke für die App läuft echt gut.
Doch bei mir wird keine Werbung gezeigt, obwohl das ja eigentlich kein Problem sein sollte.

Frage mich auch ob ich als Zuschauer gezählt werde wenn ich die PIP App benutze?
Gibt ja (anscheind) keine optische bestätigung dafür ob das überhaupt der fall ist.

In diesem Sinne, nochmals danke für deine Arbeit/Mühnen :thumbsup:


#80

Moin, Danke!
Die fehlende Werbung tritt leider bei einigen Usern auf, bei anderen funktioniert sie.
Wir konnten bis jetzt noch nicht den Auslöser dafür finden, ich vermute aber z.B. das fehlen von Flash o.Ä.

Die App nutzt den embeded player von Youtube Gaming und öffnet diesen in einem Browser Fenster, du solltest also ganz normal als User gezählt werden, so wie andere User die den Embeded Player verwenden.

Wenn du IE installiert hast, könntest du einmal prüfen ob du damit auf der Youtube Seite und auf der Youtube Gaming Seite Werbung bekommst :slight_smile: